Diesel misses and blows white smoke

Get new comments by email
You can cancel email alerts at anytime.
Comments (20)

Gep in Pompano Beach, Florida

83 months ago

Nissans are good, though?

Best regards,
David
www.travellinesexpress.com
ebooks4life.blogspot.com

- Was this comment helpful? Yes (7) / No (2) Reply - Report abuse

Brian in Cartersville, Georgia

80 months ago

you have water in your fule water causes white smoke

- Was this comment helpful? Yes (10) / No Reply - Report abuse

gearbox12 in United Kingdom

71 months ago

Hi I also have this nissan. Noticed the car last winter was misting up on the windows so much I had to use a squeegy to clear them and this week it got thrown out of the MOT place before it could be tested as it had white smoke and misfired. Help! Had injectors out and tested.All OK. Changed fuel filter,no water in it. If I rev it into the red area the smoke and misfire stops. It has been running ok but hadn't used it last week as MOT had run out. First I knew of smoke was at the MOT place! Ideas please everyone!

- Was this comment helpful? Yes (14) / No (3) Reply - Report abuse

gearbox12 in Bedford, United Kingdom

70 months ago

Hi there
Turns out the smoke was darker than I thought and the fault was the injector pump. A very high quality engine flush (made by Forte) was added and it got it through the MOT! It will do till I save for a new pump.
Many thanks.

- Was this comment helpful? Yes / No (3) Reply - Report abuse

rickblizz@verizon.net in Hampton, Virginia

66 months ago

need work real bad

- Was this comment helpful? Yes (2) / No (4) Reply - Report abuse

rickblizz@verizon.net in Hampton, Virginia

66 months ago

rickblizz@verizon.net in Hampton, Virginia said: need work real bad

water in fuel system may be cause

- Was this comment helpful? Yes (6) / No (5) Reply - Report abuse

rem599@embarqmail.com in Apopka, Florida

65 months ago

Troy in Watertown, Wisconsin said: I have a 1995 DT466. It constantly blows white smoke from the exhaust and feels like it has a miss when i am driving. Any suggestions!

With no more info than you have given, I would say you have 1 or more inj. bad, or leaking.

- Was this comment helpful? Yes (1) / No Reply - Report abuse

mario sherwin in Sudan

65 months ago

I think the injector is sticking not spray properly,water in the fuel system,

- Was this comment helpful? Yes (8) / No (2) Reply - Report abuse

zubed in Wellington, New Zealand

58 months ago

Hi.I have Nissan Terrano 2.7 Diesel and it starts late in the mornings. i wait for the glow plug light to go off before i start. onces it starts than its fine from there on. sombody was saying that i should bleed the fuel pump may be air or water is in it. How do i go about doing that any helps please?

- Was this comment helpful? Yes (1) / No (2) Reply - Report abuse

2003 altima in Westborough, Massachusetts

56 months ago

what was up with my new 2003 altima----one day the driver side window fell down out of the blue and smashed to pieces inside the door after i had the car for only a few months. then after about 100k the steering was a complete mess and nobody could seem to fix it. then the engine seized at about 140k. a very disappointing car relative to my 92 sentra---that thing was a tank !!!!

- Was this comment helpful? Yes / No (3) Reply - Report abuse

autobogger in Dublin, Ireland

55 months ago

THE SWITCH UNDER THE PUMP THAT YOU REFER TO IS CALLED A FUEL INJECTION TIMING SOLENOID SWITCH NOT LIKELY TO BE YOUR PROBLEM IF IT RUNS EVERY TIME FOR 10 SEC WITHOUT FAIL YOU COULD POSSIBLY HAVE IMMOBILISER FAULT HAVE YOU CHECKED FOR POWE TO THE STOP START SWITCH ON YHE PUMP

- Was this comment helpful? Yes (6) / No (5) Reply - Report abuse

dirtboy in Saratoga Springs, New York

53 months ago

does it do it when its hot or cold ?? could be number of things ,white is water blue is oil and black is normally unburnt fuel

- Was this comment helpful? Yes / No Reply - Report abuse

Dave in Edmonton, Alberta

40 months ago

Sounds like heads.

- Was this comment helpful? Yes (4) / No Reply - Report abuse

curtis in Livingston, Texas

38 months ago

I have a 2000 ford F250 diesel 7.3 it is pushing water back out the fill tank where you put the water what might be the problem?

- Was this comment helpful? Yes (1) / No (1) Reply - Report abuse

broncobob in Altamonte Springs, Florida

38 months ago

Could be several things. A head gasket for 1, or if you are getting fuel in the water, then look for a cracked inj. cup.If a head gasket is the culprit, you will probably get water in a cyl. and the engine will lock up. If an injector cup is cracked, the cooling system will be sqturated with fuel. There are other possibilities, but not likely. Good luck.

- Was this comment helpful? Yes (3) / No Reply - Report abuse

Davin

37 months ago

I have a 2004 Chevy 2500hd diesel it white smokes when it is warmed up and at an idole, I changed the fuel filter and there is water in the fuel. It's not a big white smog but very noticeable. Any ideas?

- Was this comment helpful? Yes (25) / No (2) Reply - Report abuse

eddie in Mere, United Kingdom

37 months ago

I have a nissan terrano 2.7 tdi. It all of a sudden started missing and puffing white smoke out, it also put engine management light on. I have put a complete engine in it with pump injectors, turbo etc and the vehicle still does the same. i was told to by pass feul filter , so i put a clear pipe out of a can straight to the pump. this has helped a bit but still got a miss when u excellerate any ideas

- Was this comment helpful? Yes (62) / No (12) Reply - Report abuse

Jabba in Cheltenham, United Kingdom

1 month ago

eddie in Mere, United Kingdom said: I have a nissan terrano 2.7 tdi. It all of a sudden started missing and puffing white smoke out, it also put engine management light on. I have put a complete engine in it with pump injectors, turbo etc and the vehicle still does the same. i was told to by pass feul filter , so i put a clear pipe out of a can straight to the pump. this has helped a bit but still got a miss when u excellerate any ideas

I have the same problem since running low on fuel and night temp hitting -3

If anyone can help

Did fault codes came back as oxygen sensor and leaky injector. I think either pump or esm/ ecu

- Was this comment helpful? Yes / No Reply - Report abuse

Jabba in Cheltenham, United Kingdom

1 month ago

Jabba in Cheltenham, United Kingdom said: I have the same problem since running low on fuel and night temp hitting -3

If anyone can help

Did fault codes came back as oxygen sensor and leaky injector. I think either pump or esm/ ecu

My problem is exactly the same Eddie . Booked into garage tomorrow if they can't do then 130 per hr Nissan job

- Was this comment helpful? Yes / No Reply - Report abuse

Jabba in Cheltenham, United Kingdom

1 month ago

Jabba in Cheltenham, United Kingdom said: My problem is exactly the same Eddie . Booked into garage tomorrow if they can't do then 130 per hr Nissan job

I did filter and air flow meter .

If yr are brave get some electric wire find yr diagnostic port if it's a ob2 port cross pin 1 and pin 8 on the wide angle and yr mil light will flash its fault code . Differ cult to work out to start with but should start ten flashes for 0 then speed up each time for two more numbers . So 045 / 10 flash , 4 flash , five flash then two three second break for next code ..... Then Google for your fault code list . Or service manual

- Was this comment helpful? Yes / No Reply - Report abuse

» Sign in or create an account to comment on this topic.