Issues with turn on after start

Get new comments by email
You can cancel email alerts at anytime.
Comments (5)

Bob Tomson in Tacoma, Washington

62 months ago

I have a 2003 ford f350 turbo diesel, no problem starting cold. After the truck is warmed up, ran, and then shut off, it will not start again for almost exactly one hour. any ideas?

- Was this comment helpful? Yes (2) / No Reply - Report abuse

Tom H. in Old Fort, Ohio

62 months ago

Bob Tomson in Tacoma, Washington said: I have a 2003 ford f350 turbo diesel, no problem starting cold. After the truck is warmed up, ran, and then shut off, it will not start again for almost exactly one hour. any ideas?

Sounds like the orings on the injection pressure regulator are bad.When the engine gets hot oil leaks past the the orings.That is assuming it is a 7.3

- Was this comment helpful? Yes (3) / No (2) Reply - Report abuse

austin T in Waco, Texas

61 months ago

Tom H. in Old Fort, Ohio said: Sounds like the orings on the injection pressure regulator are bad.When the engine gets hot oil leaks past the the orings.That is assuming it is a 7.3

I would check cps sensor (cam position sensor) common when psd's get warm

- Was this comment helpful? Yes / No (1) Reply - Report abuse

cw in Geneva, Nebraska

54 months ago

Bob Tomson in Tacoma, Washington said: I have a 2003 ford f350 turbo diesel, no problem starting cold. After the truck is warmed up, ran, and then shut off, it will not start again for almost exactly one hour. any ideas?

check your glow plugs or fuel injectors.....

- Was this comment helpful? Yes / No (1) Reply - Report abuse

Vishal in Hamilton, Ontario

53 months ago

Also post this question on mechanicshub forum you should some help from other mechanics in your trade.

Vishal

- Was this comment helpful? Yes / No Reply - Report abuse

» Sign in or create an account to comment on this topic.