iveco daily not starting from cold

Get new comments by email
You can cancel email alerts at anytime.
Comments (9)

deisel dan in Glasgow, United Kingdom

85 months ago

check compression

- Was this comment helpful? Yes (4) / No (4) Reply - Report abuse

Joe Little in Ann Arbor, Michigan

84 months ago

Check if you have Glow Plugs if so when glow plugs go bad it will cause vary hard starting when cold

- Was this comment helpful? Yes / No (3) Reply - Report abuse

Pattyjo in Saint Johns, Michigan

84 months ago

This is probably out of the ordinary but my son is ready to go to a technical school to be a diesel machanic, we live near Lansing and we are considering AIS through LCC do you know anything about this program? Are most tech. schools pretty much the same when you are earning a certificate? Please respond anyone!!!!

- Was this comment helpful? Yes / No (2) Reply - Report abuse

Joe Little in Ann Arbor, Michigan

84 months ago

You may want to consider Farris State in Eaton Rapids MI there one of the best in the country for diesel equiptment repair Good Luck.

- Was this comment helpful? Yes / No (1) Reply - Report abuse

motormek1 in Lemesos, Cyprus

67 months ago

Hi.I have an Iveco Daily 50c13 2.8 Turbo Diesel Intercooler and i'm looking for a 38 pin adaptor to 16 pin OBD .It looks the same as a Mercedes Sprinter 38 pin but has different wiring i wonder if someone can help.I have a Snap-On MT2500 Scanner and also various CanBus OBD interfaces which work through a software on my Laptop.Any information will be much appreciated.

- Was this comment helpful? Yes (14) / No (8) Reply - Report abuse

paddy in Dublin, Ireland

66 months ago

col in Ilkley, United Kingdom said: allthough i was at first sceptical i deceded to go . to my surprise the vehicle was diagnosed and repaired within the day

Can you remember what the problem was and the solution? Thanks.

- Was this comment helpful? Yes (1) / No (1) Reply - Report abuse

SB Towing

63 months ago

SS MAN in boston, Massachusetts said: i have an international 4300 rollback that i changed the oil and filter and it ran for 20minutes and the next day it wouldn't start and now the only way is by using starting fluid and when it runs out the truck will shut off. any idea what the problem can be?

I have a 2002 International 4300 I used to have to use starting fluid every morning I took it to the dealer and they changed the high pressure oil pump it is located on the drivers side front part of the engine you may want to check the connections and make sure that they are clean and making good contact.

- Was this comment helpful? Yes (4) / No Reply - Report abuse

Kitchen Fitter in South Shields, United Kingdom

61 months ago

Hi To All

Iveco Daily 213 03 wont start without easi start, Iveco dealer said they want to put on computer management system to investigate £140.0 + vat.

Any ideas on the prob and can I take it to a normal garage for repair.

Kitch

- Was this comment helpful? Yes (22) / No (8) Reply - Report abuse

sharpy in Turkey

53 months ago

iveco dailly rear brakes locked up on one side got the wheels off but cant get drum off or get the brake to release have tried hittinh it with hammer no joy any ideas

- Was this comment helpful? Yes (8) / No (2) Reply - Report abuse

» Sign in or create an account to comment on this topic.