Medford, NJ

This job posting is no longer available on CareerBuilder. Find similar jobs:Paraplanner jobs

Certified Financial Planner with an established practice based in Medford, NJ has opening for a licensed assistant / para-planner. Duties will include, but are not limited to, processing transactions, answering client questions, managing paperwork, coordinating events, and providing service to existing client base. Ideal candidate will hold a Series 7 and 66 license and NJ Life, Accident and Health. However, would be willing to sponsor the right candidate through the completion licensing process if only a Series 7 is obtained at present time. Must be able to be bonded and a background check will be performed. This is a support position, not sales based. Salary will be dependent on experience. Retirement plan and some benefits offered.The Paraplanner position is responsible for:-All client service, including account balance inquiries, responding to account benefit and feature questions, beneficiary changes, and relaying investment-related information between the advisor and the client-Assisting the advisor in creating and maintaining financial plans-Preparing new account paperwork when needed-Trading for client accounts when requested by advisor or client-Managing fee schedules, payout schedules, and other account services -Managing opportunity and other data in the Salesforce CRM systemThe right candidate will have an outstanding opportunity for advancement.
Job Requirements are as follows:-Bachelor's degree or equivalent work experience-FINRA Series 7 and 63 or 66 licensed-State of NJ Insurance Licensed or has ability to prior to hire-Minimum of 2 years experience in the investment/financial planning industry-Detail-oriented, organized, and process-minded-Able to work quickly and maintain accuracy under time constraints-Good problem-solving abilities-Able to work well in a team atmosphere-Self-motivated-A professional appearance-Proficient with Windows, Microsoft Office, and general internet navigation-Series 6 is not sufficient